UMTS, Eplus, Nokia N95 und Ubuntu

Nachdem Datentarife immer günstiger werden, habe ich das ganze mal ausprobiert.
Das N95 per USB mit dem Laptop verbunden, ein flottes

sudo apt-get install wvdial

sorgt dann für die nötige Softwareunterstützung.

Die /etc/wvdial.conf sieht bei mir dann so aus:

[Dialer Defaults]
Init1 = ATZ
Init2 = ATQ0 V1 E1 S0=0 &C1 &D2 +FCLASS=0
Init3 = AT+CGDCONT=1,“IP“,“internet.eplus.de“,““,0,0
Carrier Check = no
Modem Type = USB Modem
ISDN = 0
Phone = *99#
Modem = /dev/ttyACM0
Username = eplus
Password = gprs
Baud = 460800

Ein kleines sudo wvdial bringt einen dann online:

–> WvDial: Internet dialer version 1.56
–> Cannot get information for serial port.
–> Initializing modem.
–> Sending: ATZ
ATZ
OK
–> Sending: ATQ0 V1 E1 S0=0 &C1 &D2 +FCLASS=0
ATQ0 V1 E1 S0=0 &C1 &D2 +FCLASS=0
OK
–> Sending: AT+CGDCONT=1,“IP“,“internet.eplus.de“,““,0,0
AT+CGDCONT=1,“IP“,“internet.eplus.de“,““,0,0
OK
–> Modem initialized.
–> Sending: ATDT*99#
–> Waiting for carrier.
ATDT*99#
CONNECT
~[7f]}#@!}!} } }2}#}$@#}!}$}%}“}&} }*} } g}%~
–> Carrier detected. Waiting for prompt.
~[7f]}#@!}!} } }2}#}$@#}!}$}%}“}&} }*} } g}%~
–> PPP negotiation detected.
–> Starting pppd at Wed Sep 5 11:38:05 2007
–> Pid of pppd: 16593
–> Using interface ppp0
–> pppd: x[08][06][08]?[05][06][08]8 [06][08]
–> pppd: x[08][06][08]?[05][06][08]8 [06][08]
–> pppd: x[08][06][08]?[05][06][08]8 [06][08]
–> pppd: x[08][06][08]?[05][06][08]8 [06][08]
–> local IP address 10.161.157.130
–> pppd: x[08][06][08]?[05][06][08]8 [06][08]
–> remote IP address 10.6.6.6
–> pppd: x[08][06][08]?[05][06][08]8 [06][08]
–> primary DNS address 212.23.97.2
–> pppd: x[08][06][08]?[05][06][08]8 [06][08]
–> secondary DNS address 212.23.97.3
–> pppd: x[08][06][08]?[05][06][08]8 [06][08]

Vorher sollte man allerdings die ehemalige Defaultroute ins Netz deaktivieren (Wenn man gerade eben schon per Wlan oder sonstigem online war.)
sudo route del default

Das einzige Problem ist jetzt nur noch, dass Eplus bei UMTS die Bilder durch einen Proxy jagt und runterskaliert. Eventuell kann man das irgendwie umgehen, oder sie ändern es in absehbarer Zeit noch. Mal sehen… 😉

17 Gedanken zu „UMTS, Eplus, Nokia N95 und Ubuntu

  1. floyd Beitragsautor

    Danke. Auf die Idee bin ich bislang nicht gekommen.

    Da ich (bislang) keinen Rootserver habe, werde ich mal versuchen das ganze per dyndns und DD-WRT zu realisieren… wenn ich wieder Zeit f

    Antworten
  2. pheise

    Hi ysamjo,

    nutzt du definitiv das richtige Dev ? Bekommst du den in deiner Messages-Log die Information das dort ein Modem anmeldet wenn du dein Handy anschlie

    Antworten
  3. ysamjo

    ah sehr gut .. eingerichtet hatte ich bluetooth schon. nur das es unter /dev/rfcomm0 „eingunden“ wurde hat mir gefehlt.

    Antworten
  4. miqio

    hi floyd,

    habe auch ein n95 und probiere gerade Deine Methode. Leider antwortet das n95-modem bereits nach dem 2. Initialisierungsschritt Cannot get information for serial port:

    WvDial: Sending: ATZ
    WvDial Modem: ATZ
    WvDial Modem: OK
    WvDial: Sending: ATQ0 V1 E1 S0=0 &C1 &D2 +FCLASS=0
    WvDial Modem: ATQ0 V1 E1 S0=0 &C1 &D2 +FCLASS=0
    WvDial Modem: OK
    WvDial: Sending: AT+CGDCONT=1,”IP”,”internet.eplus.de”,”“,0,0
    WvDial Modem: AT+CGDCONT=1,b [1d]IPb [1d],b [1d]internet.eplus.deb [1d],b [1d]“,0,0
    WvDial Modem: ERROR
    WvDial: Bad init string.
    WvModem: Cannot get information for serial port.

    Mein n9WvDial: Sending: ATZ
    WvDial Modem: ATZ
    WvDial Modem: OK
    WvDial: Sending: ATQ0 V1 E1 S0=0 &C1 &D2 +FCLASS=0
    WvDial Modem: ATQ0 V1 E1 S0=0 &C1 &D2 +FCLASS=0
    WvDial Modem: OK
    WvDial: Sending: AT+CGDCONT=1,”IP”,”internet.eplus.de”,”“,0,0
    WvDial Modem: AT+CGDCONT=1,b [1d]IPb [1d],b [1d]internet.eplus.deb [1d],b [1d]“,0,0
    WvDial Modem: ERROR
    WvDial: Bad init string.
    WvModem: Cannot get information for serial port.
    5 hat mich übrigens beim einstöpseln gefragt, ob ich PC-Suite, Datentransfer, Media, oder Fotodruck möchte. Hatte mich für PC-Suite entschieden.

    Diese Modem-Probleme erinnern mich an die Anfangszeitendes Internet und solange ist es auch her, dass ich mich das letzte Mal damit befast habe.

    Einen Tipp?

    Antworten
  5. pheise

    hi, miqio

    muss bei einem n95 wirklich soviel init zeugs angegeben werden ? ich hab seit jahren nur sony ericsson und musste nichts dergleichen angeben oO

    ich kuck mal heute abend bei gelegenheit aufs alte lappy und poste meine wvdialconf … bzw falls die möglichkeit besteht bluetooth zu nutzen würde ich eher da weitertesten da es einfach nobler ist 😉 (habs auch produktiv am laufen und garkeine probleme)

    grüße

    Antworten
  6. floyd Beitragsautor

    @ miqio:

    Ich habe im Moment leider keinen Tipp, da ich zur Zeit in Österrrich wohne. 😉

    Daher kann ich im Moment auch nicht im E-Plus Netz herumspielen. Zumindest nicht ohne arm zu werden.

    Vielleicht kann ich es mir über die Weihnachtsfeiertag anschauen, dann bin ich wieder in Deutschland.

    Antworten
  7. pheise

    Hier mal meine wvdial.conf…
    Funktioniert echt Sahne, obwohl alles auskommentiert ist 😉

    pheise@zigzak:~$ cat /etc/wvdial.conf
    [Dialer Defaults]
    Init1 = ATZ
    #Init2 = ATQ0 V1 E1 S0=0 &C1 &D2 +FCLASS=0
    #Init3 = AT+CGDCONT=1,“IP“,“surfo2″
    #Init 4: AT+CGDCONT=1,“IP“,“surfo2″,““,0,0
    Modem Type = USB Modem
    Baud = 460800
    New PPPD = yes
    Modem = /dev/rfcomm0 #ttyACM0, geht auch …
    ISDN = 0
    Phone = *99***1#
    Password = eplus
    Username = wayne
    #Nameserver = 62.134.11.4
    #Nameserver2 = 195.182.110.132

    Voraussetzung hierfür denke ich ist das im Mobil ein korrekt konfiguriertes USB bzw. Bluetooth Datenprofil exisitiert … Anders kann ich mir die Probleme mit dem Einwahl-Strings nicht erklären.

    Grüße,

    Antworten

Kommentar verfassen